# ls /root/rpmbuild/RPMS/i386/
bacula-client-5.0.3-1.i386.rpm
bacula-libs-5.0.3-1.i386.rpm
bacula-updatedb-5.0.3-1.i386.rpm
bacula-debuginfo-5.0.3-1.i386.rpm
bacula-mysql-5.0.3-1.i386.rpm
Установил, привинтил все, создал базу с помощью скриптов, в общем все работает. Решил установить Webacula-5.0.2 нашел готовую rpm
ставлю:
# rpm -Uvh webacula-5.0.2-1.el5.noarch.rpm
warning: webacula-5.0.2-1.el5.noarch.rpm: Header V4 DSA signature: NOKEY, key ID 3e63d331
error: Failed dependencies:
bacula-console >= 5.0 is needed by webacula-5.0.2-1.el5.noarch
php >= 5.2.4 is needed by webacula-5.0.2-1.el5.noarch
php-ZendFramework >= 1.8.3 is needed by webacula-5.0.2-1.el5.noarch
php-json is needed by webacula-5.0.2-1.el5.noarch
И если последние Failed dependencies понятны, то bacula-console >= 5.0 is needed by webacula-5.0.2-1.el5.noarch не совсем ясна... т.к.
возможность использовать # bconsole появляется сразу после установки пакета bacula-mysql-5.0.3-1.i386.rpm
Следовательно bacula-mysql-5.0.3-1.i386.rpm ставит и bacula-console но не регистрирует пакет bacula-console отдельно в RPM базе.
А он в свою очередь требуется для установки webacula.
Я прав? И следует просто игнорировать ошибку и ставить пакет без проверки зависимостей?
Кстати номер версии webacula должен соответствовать номеру версии Bacula но 5.0.3 они еще не выпустили, Но не думаю что проблема в этом.
Скачал сейчас обычный webacula-5.0.2.tar.gz
Там русским по белому в файле webacula-5.0.2.tar.gz/webacula-5.0.2/docs/INSTALL.RU :
text
Системные требования
~~~~~~~~~~~~~~~~~~~~
- Bacula 5.0 или выше.
- Полная поддержка СУБД MySQL, PostgreSQL и Sqlite.
- Zend Framework version 1.8.3 или выше.
- Zend Framework требует PHP 5.2.4 и выше с расширением PDO. См. также:
http://framework.zend.com/manual/en/requirements.html
- Apache и mod_rewrite, либо эквивалентный веб-сервер. Например, nginx и ngx_http_rewrite_module.
- Установленный пакет php-gd для графики.
- Создание отдельной БД "webacula" для ведения Журнала.
- http://php.net/dom для RSS ленты
Запустите install/check_system_requirements.php для проверки.
Скорее всего не совсем верная проверка зависимостей в rpm.
уж не знаю почему bacula-5.0.3-1.src.rpm засовывает все в bacula-mysql-5.0.3-1.i386.rpm а не дробит по пакетам...
кто знает напишите, буду очень благодарен! wink
P.S. Может кто еще какую вебморду толковую для бакулы знает?
В общем, все установилось отлично!!!
Единственное, все еще хотелось бы получить консультацию по сборке пакетов, и по альтернативам веб морды, у кого есть ответы, все еще ВЕЛКАМ! :rolleyes: