LinuxForum.Fans
Тема

Проблема с DNS серврером CentOS

Автор: pavlar 159 сообщений 30921 просмотров
#295103
"pavlar" написал:
Я эту строку убрал потому что постоянно появлялась ошибка "ptions"

У меня сейчас такой конф

потому что здесь ошибка в конфиге, нет закрывающей фигурной скобки.

"pavlar" написал:
Я поставил но всё равно nameserver 10.44.1.1 с локальной сети не работает

выкладывай конфиг

#295104
kisil написал:
Так ТС а теперь лог последнего старта Бинда покажы
Показать
an 9 11:17:37 celebris named[8735]: BIND 9 is maintained by Internet Systems Consortium,
Jan 9 11:17:37 celebris named[8735]: Inc. (ISC), a non-profit 501(c)(3) public-benefit
Jan 9 11:17:37 celebris named[8735]: corporation. Support and training for BIND 9 are
Jan 9 11:17:37 celebris named[8735]: available at https://www.isc.org/support
Jan 9 11:17:37 celebris named[8735]: ----------------------------------------------------
Jan 9 11:17:37 celebris named[8735]: adjusted limit on open files from 4096 to 1048576
Jan 9 11:17:37 celebris named[8735]: found 4 CPUs, using 4 worker threads
Jan 9 11:17:37 celebris named[8735]: using up to 4096 sockets
Jan 9 11:17:37 celebris named[8735]: loading configuration from '/etc/named.conf'
Jan 9 11:17:37 celebris named[8735]: reading built-in trusted keys from file '/etc/named.iscdlv.key'
Jan 9 11:17:37 celebris named[8735]: using default UDP/IPv4 port range: [1024, 65535]
Jan 9 11:17:37 celebris named[8735]: using default UDP/IPv6 port range: [1024, 65535]
Jan 9 11:17:37 celebris named[8735]: listening on IPv4 interface lo, 127.0.0.1#53
Jan 9 11:17:37 celebris named[8735]: listening on IPv6 interface lo, ::1#53
Jan 9 11:17:37 celebris named[8735]: generating session key for dynamic DNS
Jan 9 11:17:37 celebris named[8735]: sizing zone task pool based on 6 zones
Jan 9 11:17:37 celebris named[8735]: using built-in DLV key for view _default
Jan 9 11:17:37 celebris named[8735]: set up managed keys zone for view _default, file '/var/named/dynamic/managed-keys.bind'
Jan 9 11:17:37 celebris named[8735]: Warning: 'empty-zones-enable/disable-empty-zone' not set: disabling RFC 1918 empty zones
Jan 9 11:17:37 celebris named[8735]: automatic empty zone: 127.IN-ADDR.ARPA
Jan 9 11:17:37 celebris named[8735]: automatic empty zone: 254.169.IN-ADDR.ARPA
Jan 9 11:17:37 celebris named[8735]: automatic empty zone: 2.0.192.IN-ADDR.ARPA
Jan 9 11:17:37 celebris named[8735]: automatic empty zone: 100.51.198.IN-ADDR.ARPA
Jan 9 11:17:37 celebris named[8735]: automatic empty zone: 113.0.203.IN-ADDR.ARPA
Jan 9 11:17:37 celebris named[8735]: automatic empty zone: 255.255.255.255.IN-ADDR.ARPA
Jan 9 11:17:37 celebris named[8735]: automatic empty zone: 0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.IP6.ARPA
Jan 9 11:17:37 celebris named[8735]: automatic empty zone: D.F.IP6.ARPA
Jan 9 11:17:37 celebris named[8735]: automatic empty zone: 8.E.F.IP6.ARPA
Jan 9 11:17:37 celebris named[8735]: automatic empty zone: 9.E.F.IP6.ARPA
Jan 9 11:17:37 celebris named[8735]: automatic empty zone: A.E.F.IP6.ARPA
Jan 9 11:17:37 celebris named[8735]: automatic empty zone: B.E.F.IP6.ARPA
Jan 9 11:17:37 celebris named[8735]: automatic empty zone: 8.B.D.0.1.0.0.2.IP6.ARPA

здесь я хочу добавить что у нас статическое распределение адресов, а здесь генерируется ключ для динамического DNS, это не лишне?

#295106
"pavlar" написал:
Jan 9 11:17:37 celebris named[8735]: listening on IPv4 interface lo, 127.0.0.1#53
Jan 9 11:17:37 celebris named[8735]: listening on IPv6 interface lo, ::1#53

Вот бинд слушает тока локальный интерфейс интересно почему.

#295107
kisil написал:
[quote="pavlar"]Jan 9 11:17:37 celebris named[8735]: listening on IPv4 interface lo, 127.0.0.1#53
Jan 9 11:17:37 celebris named[8735]: listening on IPv6 interface lo, ::1#53

Вот бинд слушает тока локальный интерфейс интересно почему.[/quote]
Может в этом вся и проблема

#295108
"pavlar" написал:
Может в этом вся и проблема

покажи named.conf

#295111
i2ks написал:
[quote="pavlar"]Может в этом вся и проблема

покажи named.conf[/quote]

Показать
GNU nano 2.0.9 File: named.conf

options {
directory "/var/named";

# Здесь указываются сервера DNS, к которым будет обращаться этот сервер в случае,
# если он сам не является хозяином домена, который резолвит. Обычно указываются
# DNS-сервера Вашего провайдера и/или DNS-сервера контроллеров домена.
# ..Например, если этот сервер спросить - какой IP у yandex.ru - то он сам не
# будет знать, зато сможет спросить у выше-стоящего сервера DNS провайдера.
forwarders {
194.44.31.225;
8.8.8.8;

};
listen-on {
10.44.1.1;
127.0.0.1;
};
# Откуда принимать DNS запросы. "any" означает - со всех интерфейсов от любого
# компьютера
allow-query { any; };
recursion yes;

# Здесь указываются адреса или подсети, с которых допускаются рекурсивные запросы.
allow-recursion {
127.0.0.1;
10.44.1.1/254;
10.44.2.1/254;
10.44.3.1/254;
10.44.4.1/254;
};
# самостоятельно известит все slave-сервера о том, что зона поменялась и ее
# необходимо перезагрузить.
notify yes;
// SECONDARY ZONES

// If you enable a local name server, don't forget to enter 127.0.0.1
// first in your /etc/resolv.conf so this server will be queried.
// Also, make sure to enable it in /etc/rc.conf.

zone "." {
type hint;
file "named.root";
};

zone "ipms.intranet" {
type master;
allow-update { 10.44.0.0/16; };
allow-transfer { 10.44.0.0/16; };
notify yes;

};

zone "localhost" {
type master;
file "named.localhost";
allow-transfer { localhost; };
notify no;

# reverse zones

zone "0.0.127.IN-ADDR.ARPA" {
type master;
};


zone "1.168.192.in-addr.arpa" {
type master;
allow-update { 10.44.1.0/254; };
allow-transfer { 10.44.1.0/254; };
};

// RFC 3152
zone "1.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.IP6.ARPA" {
type master;
};

// RFC 1886 -- deprecated
zone "1.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.IP6.INT" {
type master;
};
#295113

Попробуйте после notify yes; поставить скобку с крапкой с комой вот так

text
notify yes; 
};

и перезапустить бинд.
Что то мне кажытса что секцыя options не закрыта.
И коментарии поменяйте с # на //

#295115

После перезапуска смотрим в лог старта сервера и проверте после этого слушаетса ли 10.44.1.1

#295116
kisil написал:
Попробуйте после notify yes; поставить скобку с крапкой с комой вот так
text
notify yes; 
};

и перезапустить бинд.
Что то мне кажытса что секцыя options не закрыта.
И коментарии поменяйте с # на //

Всё равно слушается только 127.0.0.1

Показать
an 9 12:28:15 celebris named[8941]: shutting down: flushing changes
Jan 9 12:28:15 celebris named[8941]: stopping command channel on 127.0.0.1#953
Jan 9 12:28:15 celebris named[8941]: stopping command channel on ::1#953
Jan 9 12:28:15 celebris named[8941]: no longer listening on 127.0.0.1#53
Jan 9 12:28:15 celebris named[8941]: no longer listening on ::1#53
Jan 9 12:28:15 celebris named[8941]: exiting
Jan 9 12:28:17 celebris named[9055]: starting BIND 9.8.2rc1-RedHat-9.8.2-0.10.rc1.el6_3.6 -u named -t /var/named/chroot
Jan 9 12:28:17 celebris named[9055]: built with '--build=x86_64-redhat-linux-gnu' '--host=x86_64-redhat-linux-gnu' '--target=x86_64-redhat-linux-gnu' '--program-pref$
Jan 9 12:28:17 celebris named[9055]: ----------------------------------------------------
Jan 9 12:28:17 celebris named[9055]: BIND 9 is maintained by Internet Systems Consortium,
Jan 9 12:28:17 celebris named[9055]: Inc. (ISC), a non-profit 501(c)(3) public-benefit
Jan 9 12:28:17 celebris named[9055]: corporation. Support and training for BIND 9 are
Jan 9 12:28:17 celebris named[9055]: available at https://www.isc.org/support
Jan 9 12:28:17 celebris named[9055]: ----------------------------------------------------
Jan 9 12:28:17 celebris named[9055]: adjusted limit on open files from 4096 to 1048576
Jan 9 12:28:17 celebris named[9055]: found 4 CPUs, using 4 worker threads
Jan 9 12:28:17 celebris named[9055]: using up to 4096 sockets
Jan 9 12:28:17 celebris named[9055]: loading configuration from '/etc/named.conf'
Jan 9 12:28:17 celebris named[9055]: reading built-in trusted keys from file '/etc/named.iscdlv.key'
Jan 9 12:28:17 celebris named[9055]: using default UDP/IPv4 port range: [1024, 65535]
Jan 9 12:28:17 celebris named[9055]: using default UDP/IPv6 port range: [1024, 65535]
Jan 9 12:28:17 celebris named[9055]: listening on IPv4 interface lo, 127.0.0.1#53
Jan 9 12:28:17 celebris named[9055]: listening on IPv6 interface lo, ::1#53
Jan 9 12:28:17 celebris named[9055]: generating session key for dynamic DNS
Jan 9 12:28:17 celebris named[9055]: sizing zone task pool based on 6 zones
Jan 9 12:28:17 celebris named[9055]: using built-in DLV key for view _default
Jan 9 12:28:17 celebris named[9055]: set up managed keys zone for view _default, file '/var/named/dynamic/managed-keys.bind'
Jan 9 12:28:17 celebris named[9055]: Warning: 'empty-zones-enable/disable-empty-zone' not set: disabling RFC 1918 empty zones
Jan 9 12:28:17 celebris named[9055]: automatic empty zone: 127.IN-ADDR.ARPA
Jan 9 12:28:17 celebris named[9055]: automatic empty zone: 254.169.IN-ADDR.ARPA
Jan 9 12:28:17 celebris named[9055]: automatic empty zone: 2.0.192.IN-ADDR.ARPA
Jan 9 12:28:17 celebris named[9055]: automatic empty zone: 100.51.198.IN-ADDR.ARPA
Jan 9 12:28:17 celebris named[9055]: automatic empty zone: 113.0.203.IN-ADDR.ARPA
Jan 9 12:28:17 celebris named[9055]: automatic empty zone: 255.255.255.255.IN-ADDR.ARPA
Jan 9 12:28:17 celebris named[9055]: automatic empty zone: 0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.IP6.ARPA
Jan 9 12:28:17 celebris named[9055]: automatic empty zone: D.F.IP6.ARPA
Jan 9 12:28:17 celebris named[9055]: automatic empty zone: 8.E.F.IP6.ARPA
Jan 9 12:28:17 celebris named[9055]: automatic empty zone: 9.E.F.IP6.ARPA
Jan 9 12:28:17 celebris named[9055]: automatic empty zone: A.E.F.IP6.ARPA
Jan 9 12:28:17 celebris named[9055]: automatic empty zone: B.E.F.IP6.ARPA
Jan 9 12:28:17 celebris named[9055]: automatic empty zone: 8.B.D.0.1.0.0.2.IP6.ARPA
Jan 9 12:28:17 celebris named[9055]: command channel listening on 127.0.0.1#953
Jan 9 12:28:17 celebris named[9055]: command channel listening on ::1#953
Jan 9 12:28:17 celebris named[9055]: zone 0.in-addr.arpa/IN: loaded serial 0
Jan 9 12:28:17 celebris named[9055]: zone 1.0.0.127.in-addr.arpa/IN: loaded serial 0
Jan 9 12:28:17 celebris named[9055]: zone 1.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.ip6.arpa/IN: loaded serial 0
Jan 9 12:28:17 celebris named[9055]: zone localhost.localdomain/IN: loaded serial 0
Jan 9 12:28:17 celebris named[9055]: zone localhost/IN: loaded serial 0
Jan 9 12:28:17 celebris named[9055]: managed-keys-zone ./IN: loaded serial 11
Jan 9 12:28:17 celebris named[9055]: running

Может связь 127.0.0.1 с 10.44.1.1 прописывается не при старте BIND а где-то в другом месте. Ведь не случайто нужно именно 127.0.0.1 прописывать в resolv.conf чтобы функционировал местный DNS сервер. Наверное BIND 9.8так устроен что слушает лишь 127.0.0.1

#295125
"pavlar" написал:
Jan 9 12:28:17 celebris named[9055]: Warning: 'empty-zones-enable/disable-empty-zone' not set: disabling RFC 1918 empty zones

К чему бы это???

#295129
"pavlar" написал:
Может связь 127.0.0.1 с 10.44.1.1 прописывается не при старте BIND а где-то в другом месте.

может конфиг покажете все же целиком?

#295133
i2ks написал:
[quote="pavlar"]Может связь 127.0.0.1 с 10.44.1.1 прописывается не при старте BIND а где-то в другом месте.

может конфиг покажете все же целиком?[/quote]
Да я в последний раз весь конфиг показал

#295134
pavlar написал:

Показать
GNU nano 2.0.9 File: named.conf

options {
directory "/var/named";

// Здесь указываются сервера DNS, к которым будет обращаться этот сервер в случае,
// если он сам не является хозяином домена, который резолвит. Обычно указываются
// DNS-сервера Вашего провайдера и/или DNS-сервера контроллеров домена.
// ..Например, если этот сервер спросить - какой IP у yandex.ru - то он сам не
// будет знать, зато сможет спросить у выше-стоящего сервера DNS провайдера.
forwarders {
194.44.31.225;
8.8.8.8;

};
listen-on {
10.44.1.1;
127.0.0.1;
};
// Откуда принимать DNS запросы. "any" означает - со всех интерфейсов от любого
// компьютера
allow-query { any; };
recursion yes;

// Здесь указываются адреса или подсети, с которых допускаются рекурсивные запросы.
allow-recursion {
127.0.0.1;
10.44.1.1/254;
10.44.2.1/254;
10.44.3.1/254;
10.44.4.1/254;
};
// самостоятельно известит все slave-сервера о том, что зона поменялась и ее
// необходимо перезагрузить.
notify yes;

// SECONDARY ZONES

// If you enable a local name server, don't forget to enter 127.0.0.1
// first in your /etc/resolv.conf so this server will be queried.
// Also, make sure to enable it in /etc/rc.conf.

zone "." {
type hint;
file "named.root";
};

zone "ipms.intranet" {
type master;
allow-update { 10.44.0.0/16; };
allow-transfer { 10.44.0.0/16; };
notify yes;

};

zone "localhost" {
type master;
file "named.localhost";
allow-transfer { localhost; };
notify no;

// reverse zones

zone "0.0.127.IN-ADDR.ARPA" {
type master;
};


zone "1.168.192.in-addr.arpa" {
type master;
allow-update { 10.44.1.0/254; };
allow-transfer { 10.44.1.0/254; };
};

// RFC 3152
zone "1.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.IP6.ARPA" {
type master;
};

// RFC 1886 -- deprecated
zone "1.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.0.IP6.INT" {
type master;
};

#295145
"pavlar" написал:
listen-on {
10.44.1.1;
127.0.0.1;
};

для проверки: если это убрать, то он должен будет слушать все интерфейсы., ну и собственно запуска бинда сюда.

#295154
i2ks написал:
[quote="pavlar"]listen-on {
10.44.1.1;
127.0.0.1;
};

для проверки: если это убрать, то он должен будет слушать все интерфейсы., ну и собственно запуска бинда сюда.[/quote]
Абсолютно ничего не изменилось. Такое впечатление что в named.conf работает только строка forwarders

Показать
Jan 9 16:56:30 celebris named[10591]: BIND 9 is maintained by Internet Systems Consortium,
Jan 9 16:56:30 celebris named[10591]: Inc. (ISC), a non-profit 501(c)(3) public-benefit
Jan 9 16:56:30 celebris named[10591]: corporation. Support and training for BIND 9 are
Jan 9 16:56:30 celebris named[10591]: available at https://www.isc.org/support
Jan 9 16:56:30 celebris named[10591]: ----------------------------------------------------
Jan 9 16:56:30 celebris named[10591]: adjusted limit on open files from 4096 to 1048576
Jan 9 16:56:30 celebris named[10591]: found 4 CPUs, using 4 worker threads
Jan 9 16:56:30 celebris named[10591]: using up to 4096 sockets
Jan 9 16:56:30 celebris named[10591]: loading configuration from '/etc/named.conf'
Jan 9 16:56:30 celebris named[10591]: reading built-in trusted keys from file '/etc/named.iscdlv.key'
Jan 9 16:56:30 celebris named[10591]: using default UDP/IPv4 port range: [1024, 65535]
Jan 9 16:56:30 celebris named[10591]: using default UDP/IPv6 port range: [1024, 65535]
Jan 9 16:56:30 celebris named[10591]: listening on IPv4 interface lo, 127.0.0.1#53
Jan 9 16:56:30 celebris named[10591]: listening on IPv6 interface lo, ::1#53
Jan 9 16:56:30 celebris named[10591]: generating session key for dynamic DNS
Jan 9 16:56:30 celebris named[10591]: sizing zone task pool based on 6 zones
etc etc
#295162

В общем я понял что то, чем я занимаюсь, называется суходрочием. BIND 9 использует named.conf ,который создаётся автоматмчески в совершенно другой директории /var/named/chroot/etc при инсталляции (фактически это не BIND БСДюшный NAMED ), и этого named.conf даже дата создания 19 июля 2010 года, а я по какой-то дурацкой инструкции создавал сам named .conf в совершенно другойдиректории /var/named/chroot который нужен похоже как зайцу стоп-сигнал :D . ( Я напоню слова из инструкции : 2) Теперь нужно создать файл /var/named/chroot/named.conf, который в RHEL-системах сам не создается даже с минимальным конфигом. )

Я удалил этот дурацкий конфиг, рестартовал BIND и ничего не изменилось : NAMED работает с 127.0.0.1 как ни чём ни бывало с самого момента инсталляции А тот, кто этот момент знает, наверное сидит и тащится с нас втихаря :D

text
nslookup ukr.net
Server:        127.0.0.1
Address:    127.0.0.1#53

Non-authoritative answer: Name: ukr.net Address: 195.214.195.105

А в родном named .conf (котрый в /etc )как раз и указано:

Показать
//
// named.conf
//
// Provided by Red Hat bind package to configure the ISC BIND named(8) DNS
// server as a caching only nameserver (as a localhost DNS resolver only).
//
// See /usr/share/doc/bind*/sample/ for example named configuration files.
//

options {
listen-on port 53 { 127.0.0.1; };
listen-on-v6 port 53 { ::1; };
directory "/var/named";
dump-file "/var/named/data/cache_dump.db";
statistics-file "/var/named/data/named_stats.txt";
memstatistics-file "/var/named/data/named_mem_stats.txt";
allow-query { localhost; };
recursion yes;

dnssec-enable yes;
dnssec-validation yes;
dnssec-lookaside auto;

/* Path to ISC DLV key */
bindkeys-file "/etc/named.iscdlv.key";

managed-keys-directory "/var/named/dynamic";
};

logging {
channel default_debug {
file "data/named.run";
severity dynamic;
};
recursion yes;

dnssec-enable yes;
dnssec-validation yes;
dnssec-lookaside auto;

/* Path to ISC DLV key */
bindkeys-file "/etc/named.iscdlv.key";

managed-keys-directory "/var/named/dynamic";
};

logging {
channel default_debug {
file "data/named.run";
severity dynamic;
};
};

zone "." IN {
type hint;
file "named.ca";
};

include "/etc/named.rfc1912.zones";
include "/etc/named.root.key";

Так получается здесь то и надо что-то править чтобы его привязать к 10.44.1.1?

#295177

listen-on port 53 { 127.0.0.1; 10.44.1.1; };

#295184
i2ks написал:
listen-on port 53 { 127.0.0.1; 10.44.1.1; };

Прописал. С сервера через 10.44.1.1 DNS развязывается и интеренет работает

text
nslookup ukr.net
Server:        10.44.1.1
Address:  10.44.1.1#53

Non-authoritative answer: Name: ukr.net Address: 195.214.195.105

а с локального компьюьера сети

text
nslookup ukr.net
Server:        10.44.1.1
Address:    10.44.1.1#53

** server can't find ukr.net: REFUSED

Что-то ещё надо подправить :) Наверно вместо allow-query { localhost; }; поставить allow-query { any; }; ?

Гип гип ура Всё работает *YAHOO* *YAHOO* *YAHOO* *YAHOO* Cпасибо всем за терепение и помощь :)

#295206
"pavlar" написал:
поставить  allow-query     { any; }; 

Может лучше указать конкретную сеть?

#295298

То есть всё оказалось просто как палец об асфальт :)


1. Устанавливаем пакеты BIND
# yum install bind-chroot
2. Генерируем ключ
#rndc-confgen -a -c /etc/rndc.key
3. Прописываем в /etc/resolv.conf
nameserver 10.44.1.1 (ip своего сервера)
4. Правим /var/named/chroot/etc/named.conf который создаётся автоматически при инсталляции BIND 9.8.2 и приводим его к следующему виду. добавляя лишь ip своего сервера и
меняем значение allow-query по своему усмотрению. И всё :)

text
//
// named.conf
//
// Provided by Red Hat bind package to configure the ISC BIND named(8) DNS
// server as a caching only nameserver (as a localhost DNS resolver only).
//
// See /usr/share/doc/bind*/sample/ for example named configuration files.
//

options { listen-on port 53 { 127.0.0.1; 10.44.1.1; }; listen-on-v6 port 53 { ::1; }; directory "/var/named"; dump-file "/var/named/data/cache_dump.db"; statistics-file "/var/named/data/named_stats.txt"; memstatistics-file "/var/named/data/named_mem_stats.txt"; allow-query { any; }; recursion yes;

dnssec-enable yes; dnssec-validation yes; dnssec-lookaside auto;

/* Path to ISC DLV key */ bindkeys-file "/etc/named.iscdlv.key";

managed-keys-directory "/var/named/dynamic"; };

logging { channel default_debug { file "data/named.run"; severity dynamic; }; };

zone "." IN { type hint; file "named.ca"; };

include "/etc/named.rfc1912.zones"; include "/etc/named.root.key";

Делаем
#service named restart
И пользуемся в своё удовольствие :)

Войдите или зарегистрируйтесь, чтобы ответить.