LinuxForum.Fans
Тема

Проблема с libstdc++

Автор: 4fun 38 сообщений 8495 просмотров
#178412

Установил одну библиотеку, которая, судя по всему, использует libstdc++ и получаю следующую ошибку
[console]/usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.9' not found[/console]
Обновил libstdc до 4.1.2-50.el5, но, как я прочел на одном из форумов, для поддержки зависимостей нужна версия поновее, которой в репозитариях я не нашел. Есть ли у кого-то репы с более новыми версиями пакетов?
ОС: CentOS

#178413

Что за библиотеку установил?

#178415

Да на сервер игровой.
Запрашивает версию 3.4.9, а у меня 3.4.8

#178416

Попробуй взять от соответствующей версии федоры (Ф6) кажется.
Да и пора уже на CentOS 6 переходить в таких случаях.

#178422
Vascom написал:
Попробуй взять от соответствующей версии федоры (Ф6) кажется.

Можешь репозит дать, если не сложно?

Vascom написал:
Да и пора уже на CentOS 6 переходить в таких случаях.

Знать бы как) Я с линуксом работаю сравнительно недавно.

#178432

Я не знаю какой конкретно пакет тебе нужен.

#178436
Vascom написал:
Я не знаю какой конкретно пакет тебе нужен.

Но я же в первом посте написал то, что было в консоли по этому поводу

#178437

А из этого всё равно толком не понятно какой же пакет тебе надо обновить.

#178439

Что бы это значило?

Показать
[console]# rpm -Uvh http://archive.fedoraproject.org/pub/archive/fedora/linux/core/updates/testing/1/x86_64/libstdc++-3.3.2-6.x86_64.rpm
Retrieving http://archive.fedoraproject.org/pub/archive/fedora/linux/core/updates/testing/1/x86_64/libstdc++-3.3.2-6.x86_64.rpm
warning: /var/tmp/rpm-xfer.MCIZ1S: Header V3 DSA signature: NOKEY, key ID 30c9ecf8
error: Failed dependencies:
libstdc++.so.6()(64bit) is needed by (installed) libusb-0.1.12-5.1.x86_64
libstdc++.so.6()(64bit) is needed by (installed) groff-1.18.1.1-11.1.x86_64
libstdc++.so.6()(64bit) is needed by (installed) pcre-6.6-2.el5_1.7.x86_64
libstdc++.so.6()(64bit) is needed by (installed) aspell-0.60.3-7.1.x86_64
libstdc++.so.6()(64bit) is needed by (installed) iptstate-1.4-2.el5.x86_64
libstdc++.so.6()(64bit) is needed by (installed) smartmontools-5.38-2.el5.x86_64
libstdc++.so.6()(64bit) is needed by (installed) wvdial-1.54.0-5.2.2.1.x86_64
libstdc++.so.6()(64bit) is needed by (installed) coolkey-1.1.0-14.el5.x86_64
libstdc++.so.6()(64bit) is needed by (installed) redhat-lsb-3.1-12.3.EL.el5.centos.x86_64
libstdc++.so.6()(64bit) is needed by (installed) libtiff-3.8.2-7.el5_5.5.x86_64
libstdc++.so.6()(64bit) is needed by (installed) db4-4.3.29-10.el5_5.2.x86_64
libstdc++.so.6()(64bit) is needed by (installed) lftp-3.7.11-4.el5_5.3.x86_64
libstdc++.so.6()(64bit) is needed by (installed) poppler-0.5.4-4.4.el5_5.14.x86_64
libstdc++.so.6()(64bit) is needed by (installed) poppler-utils-0.5.4-4.4.el5_5.14.x86_64
libstdc++.so.6(CXXABI_1.3)(64bit) is needed by (installed) libusb-0.1.12-5.1.x86_64
libstdc++.so.6(CXXABI_1.3)(64bit) is needed by (installed) groff-1.18.1.1-11.1.x86_64
libstdc++.so.6(CXXABI_1.3)(64bit) is needed by (installed) pcre-6.6-2.el5_1.7.x86_64
libstdc++.so.6(CXXABI_1.3)(64bit) is needed by (installed) aspell-0.60.3-7.1.x86_64
libstdc++.so.6(CXXABI_1.3)(64bit) is needed by (installed) iptstate-1.4-2.el5.x86_64
libstdc++.so.6(CXXABI_1.3)(64bit) is needed by (installed) smartmontools-5.38-2.el5.x86_64
libstdc++.so.6(CXXABI_1.3)(64bit) is needed by (installed) coolkey-1.1.0-14.el5.x86_64
libstdc++.so.6(CXXABI_1.3)(64bit) is needed by (installed) libtiff-3.8.2-7.el5_5.5.x86_64
libstdc++.so.6(CXXABI_1.3)(64bit) is needed by (installed) db4-4.3.29-10.el5_5.2.x86_64
libstdc++.so.6(CXXABI_1.3)(64bit) is needed by (installed) poppler-0.5.4-4.4.el5_5.14.x86_64
libstdc++.so.6(CXXABI_1.3)(64bit) is needed by (installed) poppler-utils-0.5.4-4.4.el5_5.14.x86_64
libstdc++.so.6(GLIBCXX_3.4)(64bit) is needed by (installed) libusb-0.1.12-5.1.x86_64
libstdc++.so.6(GLIBCXX_3.4)(64bit) is needed by (installed) groff-1.18.1.1-11.1.x86_64
libstdc++.so.6(GLIBCXX_3.4)(64bit) is needed by (installed) pcre-6.6-2.el5_1.7.x86_64
libstdc++.so.6(GLIBCXX_3.4)(64bit) is needed by (installed) aspell-0.60.3-7.1.x86_64
libstdc++.so.6(GLIBCXX_3.4)(64bit) is needed by (installed) iptstate-1.4-2.el5.x86_64
libstdc++.so.6(GLIBCXX_3.4)(64bit) is needed by (installed) coolkey-1.1.0-14.el5.x86_64
libstdc++.so.6(GLIBCXX_3.4)(64bit) is needed by (installed) libtiff-3.8.2-7.el5_5.5.x86_64
libstdc++.so.6(GLIBCXX_3.4)(64bit) is needed by (installed) db4-4.3.29-10.el5_5.2.x86_64
libstdc++.so.6(GLIBCXX_3.4)(64bit) is needed by (installed) poppler-0.5.4-4.4.el5_5.14.x86_64
libstdc++.so.6(GLIBCXX_3.4)(64bit) is needed by (installed) poppler-utils-0.5.4-4.4.el5_5.14.x86_64[/console]
#178445

[console]# rpm -Uvh http://archive.fedoraproject.org/pub/archive/fedora/linux/core/updates/6/x86_64/libstdc++-4.1.2-13.fc6.x86_64.rpm
Retrieving http://archive.fedoraproject.org/pub/archive/fedora/linux/core/updates/6/x86_64/libstdc++-4.1.2-13.fc6.x86_64.rpm
warning: /var/tmp/rpm-xfer.b8GDc3: Header V3 DSA signature: NOKEY, key ID 4f2a6fd2
Preparing... ########################################### [100%]
package libstdc++-4.1.2-50.el5.x86_64 (which is newer than libstdc++-4.1.2-13.fc6.x86_64) is already installed
package libstdc++-4.1.2-50.el5.i386 (which is newer than libstdc++-4.1.2-13.fc6.x86_64) is already installed[/console]
Смущает меня тот warning.
Но нужный пакет так и не обновился, ибо пишет, что установлена последняя версия

#178447

Вот поэтому я тебе и сказал, что непонятно какой пакет тебе нужен.
И не понятно что означает ошибка в первом сообщении. Может ему glibc не нравится.

#178448

Вот статья, в которой написано:

Если вместо XBoost loaded, видите: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.11' not found (required by cstrike/dlls/modules.d/XBoost.so)

То для начала пробуем sudo apt-get install libstdc++6 (для Slackware нужно будет установить\обновить cxxlibs).
Если после этого ошибка все равно возникает, то в /etc/apt/source.list необходимо добавить еще один репозитарий с тестовой веткой дистрибутива.
Далее делаем, естественные действия:
sudo apt-get update
sudo apt-get install libstdc++6
После снова пробуем запустить сервер и подгрузить XBoost.

Да, кстати, после установки репозитариев надо было мне выполнять нечто вроде yum update или как эта команда правильно пишется для центоса?

#178450

yum update надо выполнять как можно чаще.
Ну попробуй этот пакетик от Ф7.

#178453

Можно ссылку на репу ф7? В архиве нету, а в поисковике не нашел.

#178486

Репозитарий для ф7, как и для ф6, тоже не подключается
Имею только эти репы

Показать
[console]# yum repolist
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
* addons: [url=ftp://ftp.tlk-l.net]ftp.tlk-l.net[/url]
* base: [url=ftp://ftp.tlk-l.net]ftp.tlk-l.net[/url]
* epel: [url=ftp://ftp.tlk-l.net]ftp.tlk-l.net[/url]
* extras: [url=ftp://ftp.tlk-l.net]ftp.tlk-l.net[/url]
* updates: [url=ftp://ftp.tlk-l.net]ftp.tlk-l.net[/url]
repo id repo name status
CentALT CentALT Packages for Enterprise Linux 5 - x86_64 enabled: 269
addons CentOS-5 - Addons enabled: 0
base CentOS-5 - Base enabled: 3,535
epel Extra Packages for Enterprise Linux 5 - x86_64 enabled: 6,540
extras CentOS-5 - Extras enabled: 299
updates CentOS-5 - Updates enabled: 749[/console]
#178511

Установил еще rpmforge. Эффекта никакого

Войдите или зарегистрируйтесь, чтобы ответить.