LinuxForum.Fans
Тема

Fedora17 + sams2 + squid

Автор: grinka 2 сообщений 3190 просмотров
#336001

Установил на fedora17 sams2.
Статистика работает трафик считается, но не работает ограничение по трафику и ограничение к доступу к сайтам.

По началу sams вообще не добавлял правила в squid.conf. Потом я прописал в squid следующие строки:
#
# Следующие строки управляются SAMS
#

# TAG: acl

# TAG: http_access

#Конец управляемых настроек
http_access deny all

после добавление этих строчек, я нажал переконфигурить squid и получил следующие:
#
# Следующие строки управляются SAMS
#

# TAG: acl
acl Sams2Time1 time MTWHFAS 23:00-23:59
acl Sams2Template1 src 192.168.0.132
acl Sams2Template1 src 192.168.0.57

# TAG: http_access
# Setup Sams2 HTTP Access here
http_access allow Sams2Template1

#Конец управляемых настроек
http_access deny all

Но доступ так и не стал блокироваться....

Привожу вам полную конфигурацию squid:

#acl localnet src 10.0.0.0/8 # RFC1918 possible internal network
acl localnet src 192.168.0.0/16 # RFC1918 possible internal network
#acl localnet src 192.168.0.0/16 # RFC1918 possible internal network
acl localnet src fc00::/7 # RFC 4193 local private network range
acl localnet src fe80::/10 # RFC 4291 link-local (directly plugged) machines
acl SSL_ports port 443
acl Safe_ports port 80 # http
acl Safe_ports port 21 # ftp
acl Safe_ports port 443 # https
acl Safe_ports port 70 # gopher
acl Safe_ports port 210 # wais
acl Safe_ports port 1025-65535 # unregistered ports
acl Safe_ports port 280 # http-mgmt
acl Safe_ports port 488 # gss-http
acl Safe_ports port 591 # filemaker
acl Safe_ports port 777 # multiling http
acl CONNECT method CONNECT
http_access allow localhost manager
http_access deny manager
http_access deny !Safe_ports
http_access deny CONNECT !SSL_ports
http_access allow localnet
http_access allow localhost
http_access deny all
http_port 192.168.0.1:3128 intercept
coredump_dir /var/spool/squid
refresh_pattern ^ftp: 1440 20% 10080
refresh_pattern ^gopher: 1440 0% 1440
refresh_pattern -i (/cgi-bin/|\?) 0 0% 0
refresh_pattern . 0 20% 4320

#
# Следующие строки управляются SAMS
#

# TAG: acl
acl Sams2Time1 time MTWHFAS 23:00-23:59
acl Sams2Template1 src 192.168.0.132
acl Sams2Template1 src 192.168.0.57

# TAG: http_access
# Setup Sams2 HTTP Access here
http_access allow Sams2Template1

#Конец управляемых настроек
http_access deny all

Уже не знаю куда рыть... Помогите разобраться.

#336005

Что то в конфиге ещё не хватает для ограничения скорости и для блокировки. Вы всё верно сделали по мануалу????

Войдите или зарегистрируйтесь, чтобы ответить.