LinuxForum.Fans
Тема

IP addresses

Автор: Peter 35 сообщений 5488 просмотров
#234118

drBatty, естественно я имел ввиду адрес сети :) и маску же дописал..

Что касается последнего нуля, то с учётом /24 (работают 24 первых бита) там можно писать вообще что угодно, но принято писать 0.

если я допишу что угодно, то это будет адрес машины, а не сети.

#234138
riso написал:
естественно я имел ввиду адрес сети smile и маску же дописал..

угу. уверен, многие не поймут.

riso написал:
если я допишу что угодно, то это будет адрес машины, а не сети.

нет. там можно писать всё что угодно, или вообще не писать ничего 192.168.1/24
можно и так 192.168.1.123/24 это тоже самое.
Но таки правильнее ничего не писать, или писать ноль.

#234140

можно и так 192.168.1.123/24 это тоже самое.

это адрес машины

192.168.1/24

а это не правильная запись, т.к. тоже указана маска..

#234146
riso написал:
можно и так 192.168.1.123/24 это тоже самое.

это адрес машины
[quote]192.168.1/24

а это не правильная запись, т.к. тоже указана маска..[/quote]
обе записи рабочие. Можно проверить. Что до стандарта - лень копаться. IRL применяют обе формы, и не комплексуют.

#234148

Мне просто показалось, что вы хотите сказать, что 192.168.1.123/24 это адрес сети. На счет192.168.1/24 записи спорить не буду, т.к. не применяю.

#234185
riso написал:
Мне просто показалось, что вы хотите сказать, что 192.168.1.123/24 это адрес сети.

это адрес сети и есть.
Он покрывает 2^(32-24) == 2^8 == 256 адресов. причём сразу.

riso написал:
На счет192.168.1/24 записи спорить не буду, т.к. не применяю.

очень удобно, например 10/8 это локальная сеть класса А.

ЗЫЖ да, для любителей венды: в первом случае маска 255.255.255.0, а во втором 255.0.0.0. ну так она пишет почему-то.

#234250

Он покрывает 2^(32-24) == 2^8 == 256 адресов. причём сразу.

да, маска 24 покрывает 256 адресов, соглашусь. Но 123 в конце - это адрес машины. Поэтому при записи 192.168.1.123/24 имеется ввиду адрес машины, а при записи 192.168.1.0/24 - адрес сети.

#234300
drBatty написал:
[quote=bormant]Сеть класса "C" -- 254 машины, класса "B" -- 65534, класса "A" -- 16777214.

поправочка.
10.0.0.0/8 Private-Use Networks [RFC1918] A 16777216 адресов
172.16.0.0/12 Private-Use Networks [RFC1918] B 1048576 адресов
192.168.0.0/16 Private-Use Networks [RFC1918] C 65536 адресов
пруф http://tools.ietf.org/html/rfc3330[/quote]
В огороде бузина, а в Киеве дядька. В исходном сообщении речь о классах сетей, а в поправочке о приватных диапазонах.

RFC3330 Special-Use IPv4 Addresses описывает диапазоны адресов IPv4 специального назначения (неожиданно wink ).
http://tools.ietf.org/html/rfc1918 говорит прямо, что под приватные адреса выделена 1 сеть класса "A", 16 последовательных сетей класса B и 256 последовательных сетей класса "C".


3. Private Address Space

The Internet Assigned Numbers Authority (IANA) has reserved the
following three blocks of the IP address space for private internets:

10.0.0.0 - 10.255.255.255 (10/8 prefix)
172.16.0.0 - 172.31.255.255 (172.16/12 prefix)
192.168.0.0 - 192.168.255.255 (192.168/16 prefix)

We will refer to the first block as "24-bit block", the second as
"20-bit block", and to the third as "16-bit" block. Note that (in
pre-CIDR notation) the first block is nothing but a single class A
network number, while the second block is a set of 16 contiguous
class B network numbers, and third block is a set of 256 contiguous
class C network numbers
.

Сеть класса "A" -- это /8, "B" -- /16, "C" -- /24. Без вариантов. RFC870.

Далее, поскольку 0-й и последний адрес использовать для хоста нельзя (один из них адрес сети, другой широковещательный), получим указанные в исходном сообщении цифры.

#234303
riso написал:
при записи 192.168.1.123/24 имеется ввиду адрес машины, а при записи 192.168.1.0/24 - адрес сети.

Кем имеется? На каком основании?
map 192.168.1.123/24 будет сканировать только 1 хост?

Адрес хоста -- это всегда /32 (255.255.255.255).

ps. Просто примените маску и вопросов не останется.
x.x.x.Y & 255.255.255.0 == x.x.x.0

#234349

хорошо, nmap действительно просканирует всю сеть, здесь я согласен с вами.

Address: 192.168.1.123 11000000.10101000.00000001. 01111011
Netmask: 255.255.255.0 = 24 11111111.11111111.11111111. 00000000
Network: 192.168.1.0/24 11000000.10101000.00000001. 00000000

Address: 192.168.1.123

#234362

riso,
извините, не понял, что хотели сказать, что подтвердить или опровергнуть.

address -- с англ. адрес.

192.168.1.123, 192.168.1.123/32 -- адреса хоста, никто не спорит.
192.168.1.123/24 -- адрес сети

Класс сети, в данном случае "C", определён по первым 3 битам адреса в полном соответствии с ранее помянутым RFC870. Согласно классу приведены маска сети и адрес сети, который можно писать 192.168.1/24 или с любым числом Y как 192.168.1.Y/24.

ps. Сложилось ощущение, что употребляя слово "сеть", имеете в виду что-то ещё кроме группы IP адресов с одинаковым префиксом. Задание маски кроме /32 -- уже само по себе есть указание на группу адресов из более чем одного.

#234385

я имел ввиду скорее человеческий фактор, нежели машинный. Обычно я говорю, задай адрес компа 192.168.1.2 и маску /24, и человек сразу понимает о чем речь. Извините если забил топик какой-либо глупостью.

#234433
riso написал:
я имел ввиду скорее человеческий фактор, нежели машинный. Обычно я говорю, задай адрес компа 192.168.1.2 и маску /24, и человек сразу понимает о чем речь.

почему именно /24? Почему не /30 или даже не /31?

#234441

обычно у меня сети с маской 24, поэтому.

#235744
drBatty написал:
[quote=Peter]вот "arp -a" вывела адрес шлюза - 192.168.0.1, это ближе всего к тому, что я хотел.

ну попробуйте конечно этот свой arp, может что и получится http://www.opennet.ru/man.shtml?topic=arp&category=7&russian=0[/quote]
arp выводит только те адреса, к которым было обращение, т.к. работает с кэшем.
nmap может и не баыть установлен, но с ним я ещё не разбирался.

Пётр.

Войдите или зарегистрируйтесь, чтобы ответить.